Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    Hi all,

    I tried looking for this in previous discussions, unsuccessfully, so hopefully I am not repeating something well-known. My question is how the search engine in MO handles LaTeX code in titles. Specifically, I was trying to search for any new questions on my favourite topic, the Lie group $G_2$. When I search for 'g2' or 'G_2' or even '$G_2$, I get lots of hits, including, for example:

    which has LaTeX code $G_2$ in the title. But what does *not* come up, is this question:

    which also has $G_2$ in the title. I couldn't figure out why. Anyone have any ideas? [Of course, given that my answer to that question is my most useful contribution to MO thus far, it's in my interest for the question to show up properly on searches...] It also makes me wonder if there are other questions I might be interested in finding that aren't showing up for similar reasons...?



    Hi Spiro,

    There are a few issues with this kind of search. Briefly:

    1. Searching for LaTeX code is always a bit problematic (G_2, G_{2}, \newcommand{\Gee}[1]{\ensuremath{G_{#1}}}\Gee2, etc.)
    2. The MO search box is not very sophisticated. It's not designed to handle this kind of query. (This will get better after we migrate.)
    3. It's better to use Google since it heavily indexes MO. Question 49357 is the first hit when I query " G_2" (individual results may vary).

    Our tips page has some useful info for searching MO.



    The search in SE 2.0 is indeed better and slightly more sophisticated, but it still lacks a lot of options; not to mention that the LaTeX support is still abysmal and nonexistent.

    Hi Fran├žois,

    Thanks for explaining this to me. I guess question 49357's title has "G_2" typeset in some way other than those I tried. It's good to know that it's preferable to use google.


    49357's raw title is '$G_2$ and Geometry'
    Well, then I am more confused now. Because searching for $G_2$ does not find that question, but it does find 97059. Weird.

    It's not a big deal, since I've taken the advice to use google from now on, but it's still curious.