Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorAndrea
    • CommentTimeApr 28th 2010 edited

    Uhm... that's strange. Can you try logging in directly with myopenid and tell me whether it works?

    EDIT: in the meantime I tried to login with (of course I don't know your credentials, so I went only up to the point where I should authenticate) and I'm indeed redirected to a Google page. Which is strange, because I tried using delegation on my web page, which redirects to a myopenid account, and I'm correctly logged in via myopenid. In other words, works for me :-)

    EDIT: Ok, I found what's wrong. You should actually enter a URL, that is, "" rather than "". I may correct that for next version: addresses without a protocol will be given the prefix "http://". Why unknown addresses are redirected to Google is a mystery to me, I can only guess it's due to the library I use (I certainly hope it's not part of the protocol :-P)

    • CommentAuthorAndrea
    • CommentTimeMay 3rd 2010

    @Scott: The bug you found is now corrected. At the same time I have made some small improvements: added "Share this on..." links, and made the navigation better in long sections (for instance you can now have a link like this ).



    I can now login (although there's a strange blank page with just a "Continue" button that isn't part of the usual OpenID sequence), but when I try to submit a book I get: "You do not have access to this action. Please login."

    • CommentAuthorAndrea
    • CommentTimeMay 6th 2010 edited
    @Scott: As for the blank page, it is introduced by the library I use. I guess an automatic redirect is part of the OpenID login process, and that page is for those whose browser do not support that. If that is the case, I'd rather not take it away.

    About the authorization issues, I don't know. The very fact that you were able to click on the "Add book" button shows that you were correctly logged in. Would you mind trying again and telling me the outcome? The only thing I can think of right now is that maybe you just did something else for a while, and then when you submitted the book you were logged of.
    Indeed for some reasons, when I introduced OpenId I broke the "Remember me" feature. I am going to fix it in next update. Withouth the "Remember me" feature, the session timeout is very short, I think 10 minutes of inactivity. That is the default of my framework, for security reasons. I might raise that, but I'd rather fix the "Remember me" option instead.