Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    Apologize in advance if I'm posting in the wrong place, but I have been working with MathJax and have a browser problem to report with the LateX \overline macro. I have a webpage which makes use of this, and it renders fine in firefox, renders but not at the proper height in chrome, and is completely invisible in safari. I searched on overline and no one else seems to have reported this. I also note that this is the case (as described above for each of the browsers) for \sqrt, which presumably invokes \overline.

    Apologize in advance if I'm posting in the wrong place

    Yes you are. General MathJaX bugs should be reported on the MathJaX support site. This is for MathJaX rendering on MathOverflow, and only on MathOverflow.

    • CommentAuthorMTS
    • CommentTimeFeb 2nd 2012 edited

    MathJax appears not to be rendering at all for me now. It works fine for example on MathSciNet, but not on MO. I am using Firefox 9 on Ubuntu. Any thoughts?

    Edit: I figured out what the problem was. I was connecting to the internet through a proxy server (the UC Berkeley library proxy, if it matters) and that was making MO not work. It seems that the problem was specific to StackExchange-type sites. I discovered it when I tried to find something on the AskUbuntu StackExchange site - there was a bar at the top saying that the page was trying to load JavaScript from another domain and that the browser was blocking it. Anyway, turning off the proxy worked - now I use the FireFox plugin FoxyProxy which allows you to switch proxies based on url patterns, so I don't have to manually change it all the time.

    • CommentAuthorDavid White
    • CommentTimeFeb 13th 2012 edited
    Having just reached 2K reputation, I thought I'd edit a post to fix some bad latex. I got it to display in the Preview Math mode but for some reason it breaks again after I save my edit. Here's the question:

    Any ideas on what could cause this?

    EDIT: Using backticks fixed the problem. Thanks to those who posted early in this thread about that particular life-saving measure.
    • CommentAuthorscaaahu
    • CommentTimeFeb 14th 2012 edited

    I don't know where to report this issue. If this is wrong place, please direct me to the right one.

    I am using Windows Vista and IE9. I was trying to print

    The math symbols like SL_3(Z) disappeared from the Question part.

    The math symbols in the first answer look ok. Have trouble with printing the second answer.

    Using Print Preview showed the same result. I'd like to know if it's my OS/browser/printer problem, or something I won't be able to fix on my end. Thanks.


    @scaaahu, perhaps you could post the printed version somewhere, so we can have a look? It's a bit hard to guess what's happening if you just say that you "Have trouble". I'm guessing that MathJax hasn't been carefully tested in IE9's print preview mode. Perhaps you might try a better browser? :-)

    • CommentAuthorscaaahu
    • CommentTimeFeb 15th 2012
    "MathJax hasn't been carefully tested in IE9's print preview mode" is probably the reason.

    "Have trouble" means the errors are not consistent. The first part the print out of the second answer looked ok. Then I started to see gabbage stuff in the last part of the second answer.

    As far as I know, IE9 is the newest IE on Windows. By "better browser" did you mean Firefox?

    I am a retiree sharing the computer with my wife. There is no way I can take the computer away from her and install another browser. I might try the printing in the local library. They have Windows XP and IE8.

    @scaahu. Unfortunately I can't help identify the error, I don't have access to any windows computers. Does anyone else here have access to IE9? Also, it's perfectly possible to install a second browser in windows, without changing anyone else's experience. (E.g. install Google Chrome, easy to use and relatively excellent security, and as long as you don't set it as the default browser other users of the computer needn't even notice.)


    @scaaahu: I don't have a solution, but perhaps you can indicate if I've reproduced your problem. The computers in the Caltech math department run windows with IE 8. When I try to print to pdf, I get the following error from distiller:

    %%[ ProductName: Distiller ]%%
    MathJax_Math-Italic not found, using Courier.
    MathJax_Main-Regular not found, using Courier.
    MathJax_Main-Bold not found, using Courier.
    %%[ Error: invalidfont; OffendingCommand: show ]%%
    %%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
    %%[ Warning: PostScript error. No PDF file produced. ] %%

    Print preview (and printing on an actual printer) both work, with the following horrible result:

    awful printing

    • CommentAuthorscaaahu
    • CommentTimeFeb 16th 2012
    Thanks Anton. My printout is different but similar. However, It is much better after I used IE -> Tools -> Compatibility View. I believe there are probably two issues at hand. One is IE9 vs. IE8. The other is that the printing of the question part of that thread is different from the answer part. Could somebody try the print out or print preview by using other browsers on other OS? MO is for everybody. We don't want to see different behaviors because of different browsers/OS, right?

    Well, within limits. I'm pretty happy, unfortunately for some, to not aspire to IE "compatibility". On the other hand, this looks very likely to actually be some interaction between IE, MathJax (and possibly the way we load fonts for MathJax?), and as such the MathJax folks are likely to be interested. Can you print from any one sites that use MathJax?

    • CommentAuthorscaaahu
    • CommentTimeFeb 21st 2012
    I tried print preview of couple of threads on Math SE and TCS SE. See no problem. I have not found any thread worth printing on the paper yet - ink is very expensive - I am a retiree. Will report here when I see printing problem. Any other site worth trying?

    The spacing in math rendering looks terrible for me right now. I'm using firefox 3.6.17 on linux. It appears as though negative space is being inserted after every bit of math, so that the math runs over the text which immediately follows (Added: the amount of negative space is roughly proportional to the number of symbols in the math). Just about any question is showing this: is one where it is obvious.


    Am I the only person seeing this?

    • CommentAuthorWillieWong
    • CommentTimeMar 26th 2012

    @Charles: I don't know if you are the only one, but I am not seeing the problem. FWIW I am running Firefox 8 on linux. Is it possible for you to update to a slightly newer version of firefox at all?


    The machine at work is firefox 3.5.3 on linux; on there everything displays fine (which is good since I can't update this machine).

    Hello, I am unable to make this appear properly:
    We consider the set

    '$$ S = \lbrace (F,h):F is a decreasing function from R^{+} to R^{+}, h\in R, 0=1- \frac{\theta + 1}{\theta} \frac {\int^{h}_{y=0} F(y) dy}{F(0)} \frac{F(0)-\frac{1}{2}F(h)}{F(0)-F(h)} \rbrace $$'

    The function L is defined on S by

    '$$ L(F,h) = \frac{ \int^{h}_{x=0} \int^{h}_{y=x} F(y) dy dx} { \int^{h}_{x=0} \int^{h}_{y=0} F(y) dy dx} h $$'

    @Lennart: Try

    We consider the set
    `$$ S = \left\lbrace (F,h)\;\;\middle\vert\;\genfrac{}{}{0pt}{}{F\text{ is a decreasing function from }R^{+}\text{ to }R^{+}, h\in R}{0=1- \dfrac{\theta + 1}{\theta} \dfrac {\int^{h}_{y=0} F(y) dy}{F(0)} \dfrac{F(0)-\frac{1}{2}F(h)}{F(0)-F(h)}} \right\rbrace $$`
    The function $L$ is defined on $S$ by 
    `$$L(F,h) = \dfrac{\int^{h}_{x=0} \int^{h}_{y=x} F(y) dy dx}{\int^{h}_{x=0} \int^{h}_{y=0} F(y) dy dx} h$$`
    Thanks! Now it is working.
    I recently attempted to give an answer to a question. The answer is rather long, so after a certain amount of typing my answer no longer was shown in the preview. Then I posted the incomplete answer to see if the problem was with the preview. It so happens that the posted answer was cut of short of the amount of typing, so I deleted the answer, as not to leave an incomplete answer. I do not think that the problem is that the anser is too long since I have seen a few long answers.
    Should I undelete the answer, so that one may have a look at it, post a link?
    • CommentAuthorWill Jagy
    • CommentTimeSep 23rd 2012
    Spice, i am willing to look at it, just post the question number here, any 10K user will be able to see. i can say that I have often had trouble composing on site. My habit is to compose anything long on my home computer in Latex. Once that is right, copy and paste into an MO answer window. Then I make certain changes, for example double backslashes for lines in a matrix must have a third backslash added. Also, it used to attempt to render my stuff as I went along, which was horrible. I'm not sure what I did, but now there is a button at the bottom, something along the lines of One-Time Preview, which attempts to render my code but only when I ask. This is much better.
    Thank you Will. The question is one of mine that I finnaly found an answer. The link is .
    It is the longer of the two answers. After the problem is figured figured out, I need to make some edits (clean the answer).
    • CommentAuthorWill Jagy
    • CommentTimeSep 23rd 2012
    Spice, the longer visible (though deleted) answer dies out at:

    "We will now put an equivalence relation on the set of leaves. Let L1,L2 be two leaves. Then they are equivalent if sup(L1,L2) has the property that $sup(L_1,L_2)"

    while your underlying edit window shows

    "We will now put an equivalence relation on the set of leaves. Let $L_1, L_2$ be two leaves. Then they are equivalent if $sup(L_1,L_2)$ has the property that $sup(L_1,L_2)<V\leq L_i$ implies that $V=L_i$. This equivalence relation will partician the set of leaves as follows: $ P_1,P_2,\ldots P_k$
    Note that the group, $AUT(P_1)\times\ldots AUT(P_k)$ will provide a natural isomorphism between the functor $F_T$ and itself. $if $\sigma\in AUT(P_1)\times\ldots AUT(P_k)$, then $\sigma$ give rise to an endofunctor, $cell^n\rightarrow cell^n$,by permuting the appropriate factors. We will abuse the notation and denote this functor by $\sigma$."

    Perhaps moderators can see more, but from my viewpoint there is some kind of problem. To minimize frustration, I suggest you copy your whole edit window contents into a Latex document at home, work on it there until it is all ready. Then open up the edit window for your answer again, delete the stuff there now, paste in the good Latex code, save, preview, finally undelete. As an alternative you can just make a third answer.

    I use this method, as a result i have never tried to learn MathJax. Just a handful of quick fixes from Latex to MathJax or whatever. I keep a big file I call MathOverthrow.tex. Each time I want to compose something I put in a \newpage command, then tack on new material until it comes out right. At this point, it is about 89 pages, mostly because I keep interrupting things to start a new page.
    Thank you Will. I have my work saved in an email. I will take your advice.

    Always put a space after "<" (or use "\lt" instead) since "<whatever" might be interpreted as the start of an xml tag.

    That did the trick François. Thank you.
    • CommentAuthorNithilher
    • CommentTimeNov 12th 2012
    Problem with \mathfrak
    The following input (within proper LaTeX equation delimiters) yields in a blank white space

    \textrm{m}\left(\frac12,\ldots,-i\right) = \int\int\int
    \tilde{\cal E}({{\cal K}'}^4,\bar d\!\infty)\ \ dA_W\,.

    If I omit the \mathfrak, everything is fine. At other occurences, \mathfrak renders fine.

    Does adding braces, like \tilde{\mathfrak{t}}, help? It seems that way, but I only tested it in an editor preview over on faketestsite.

    • CommentAuthorJim White
    • CommentTimeJan 12th 2013
    If an answer on mathoverflow has more than 5 comments, you have to click on "add/show more comments".

    When I do that, mathjax rendering is not done, even in the first 5 comments, which revert to their unrendered form.

    I'm using IE9 as the browser, if that makes any difference.

    When I type a $$displayed equation$$ it tends to show up pretty far right of center in the preview. Is this a browser issue? (Chrome). I usually just leave some space and use single dollar signs.

    • CommentAuthorWillieWong
    • CommentTimeJan 25th 2013

    @Jim White: it could be an IE9 problem. On IceWeasel / Firefox on Debian, works with no problems when uncollapsing comments.


    Looks like my hosting is having a bad afternoon, so both meta and mathjax on the main site may be a bit flaky.

    If it continues, I'll work out how to move the mathjax files somewhere more reliable.

    • CommentAuthori707107
    • CommentTimeMay 8th 2013
    Suddenly from last night, the LaTex code for formulas inside sentence (formula between single dollar signs) do not work.
    But formulas between two dollar signs work fine.
    Can anyone explain why something like $\mathsf{AD}_{\mathbb R}$ works sometimes and other times it doesn't? (When it doesn't, the text after {AD} appears emphasized.)


    we've just upgraded MathJax to 2.2-beta. Briefly, it was setup incorrectly, causing your issue. It should be resolved now (and is for me). If you're still seeing the problem, try the usual tricks for clearing your cache (restart your browser, clear the cache for, and if the problem is still there let us know.


    @Andres, could you point to an example page where you're seeing this issue?

    • CommentAuthori707107
    • CommentTimeMay 8th 2013
    @Scott Morrison, after I deleted all cache, I am still seeing the same problem.
    • CommentAuthori707107
    • CommentTimeMay 8th 2013
    @Scott Morrison, actually the problem resolved for me. but the formulas show up a lot slower than before.
    Scott: One was another was In both cases, I replaced the subscript with parentheses, as in $\mathsf{AD}(\mathbb R)$ and $\mathsf{DC}(\mathbb R)$.
    • CommentAuthorjoro
    • CommentTimeMay 9th 2013

    Latex rendering doesn't work for me too. Maybe since yesterday. Clearing cache and restarting the browser doesn't help. "(Re)process math with jsMath." helps.

    "(Re)process math with jsMath." is not consistent - sometimes the latex is smaller without context menu, sometimes it is the usual way with context menu.

    • CommentAuthorAngelo
    • CommentTimeMay 9th 2013
    LaTeX rendering works for me, but it has become a lot slower than it used to be. I use Firefox 20.0 on a Macbook, OS X 10.8.3. I delete the cache and restarted the browser, to no avail. I see the same issue with Safari.
    MathJax works but is ridiculuously slow. Rendering the following took ten seconds:

    There is no problem with rendering at , where the new MathJax version is used too.
    • CommentAuthorEmil J
    • CommentTimeMay 9th 2013
    Rendering is also awfully slow for me. More precisely, after loading the page, it takes about15–20 seconds before anything starts to happen with the MathJax snippets. Then the equations start to render at normal speed.

    Same for me as Angelo, Michael G and Emil J, on two different computers, using Firefox 17 and 20 on two different Linux distributions.

    • CommentAuthoredenharder
    • CommentTimeFeb 20th 2014

    $x_\mu$ and $y_\mu$ will produce something like $x muandy \mu$ with my mathjax, but the Mathjax used by Math.SE can copy with $x_\mu$ and $y_\mu$ properly. The setting for my mathjax is as following:

    <script type="text/x-mathjax-config"> MathJax.Hub.Config({"HTML-CSS": { preferredFont: "TeX", availableFonts: ["STIX","TeX"], linebreaks: { automatic:true }, EqnChunk: (MathJax.Hub.Browser.isMobile ? 10 : 50) }, tex2jax: { inlineMath: [ ["$", "$"], ["\(","\)"] ], processEscapes: true, ignoreClass: "tex2jax_ignore|dno",skipTags: ['script', 'noscript', 'style', 'textarea', 'pre', 'code']}, TeX: { noUndefined: { attributes: { mathcolor: "red", mathbackground: "#FFEEEE", mathsize: "90%" } }, Macros: { href: "{}" } }, messageStyle: "none" }); </script> <script type="text/x-mathjax-config"> MathJax.Hub.Queue(function() { var all = MathJax.Hub.getAllJax(), i; for(i=0; i < all.length; i += 1) { all[i].SourceElement().parentNode.className += ' has-jax'; } });

    What should I do in my own setting? Many thanks!