Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthorMariano
    • CommentTimeJan 7th 2011

    Since sometime today, I have had firefox from time to time pop up a dialog telling me that mathjax is taking to long on MO's pages.

    Has something changed?


    I updated MathJax last night. I think the problem stems from some bits of being new while other bits are old cached stuff. Clearing the cache seems to fix the problem.

    Is there some easy way to avoid this problem with future updates? Does anybody know how to tell Apache something like "if somebody fetches this file, tell them that this bunch of other files have changed"?

    • CommentAuthorMariano
    • CommentTimeJan 7th 2011

    I doubt HTTP itself supports that. Asking on Freenode's #httpd suggests other people think so too :)

    • CommentAuthorHJRW
    • CommentTimeJan 7th 2011

    I cleared my cache, but MathJax still isn't working.


    I have also had problems, severe enough to cause me to switch to Internet Explorer when viewing MO.

    • CommentAuthormarkvs
    • CommentTimeJan 7th 2011
    MathJax does not work with any of the browsers: Chrome, IE, Firefox.

    MathJax has stopped working for me as well (I also cleared my cache). Chrome's Javascript console gives the error

    Uncaught SyntaxError: Unexpected token :


    Mathoverflow has been consistently crashing Chrome on my Mac, but not Firefox.

    • CommentAuthormarkvs
    • CommentTimeJan 7th 2011
    Chrome: Uncaught SyntaxError: Unexpected token :

    It looks like this is because of a typo in the Opera fonts fix. I've fixed the typo.

    To handle the caching problem, I've tried the following scheme. I've made an exact copy of the mathjax directory (mathjaxcopy) and pointed the footer (which loads MathJax) to the copy. Since the path to the file is different, I think your browser has to actually fetch the file. Of course, if you have the footer cached, that will have to refresh first.

    Sorry about all the trouble. Thanks for the reports.


    I've posted a system message on MO. I believe clearing the footer from your cache will now do the trick, but I have a very small sample size. If this works for you (or doesn't), please comment here so that I know if the problem really is resolved.

    • CommentAuthormarkvs
    • CommentTimeJan 7th 2011
    seems to work with all browsers now.
    • CommentAuthorSJR
    • CommentTimeJan 7th 2011 edited
    I'm still having the same problem, with Chrome on Lucid-Lynx. When chrome stalls, it either stops loading the page before the Latex is processed, or it gives a message saying that the thread corresponding to the browser tab in question is not responding, and what would I like to do? Clearing the cache doesn't help.

    I am now okay logging in to MO using Firefox. Thanks for fixing the problem.


    @SJR: are you still having the same problem? Do you have it in multiple browsers?

    On my macbook I use Safari, and have glims reopen my windows from the last session. I have about 4 windows pointing to things on mathoverflow. Starting sometime last week when I start up Safari after turning on my macbook I get popups for all the MO windows saying that a script is taking took long. If I click on "Continue" it just keeps happening. What I have to end up doing is to stop all the scripts on the MO pages, quit safari, and then restart it -- restoring the tabs. Everything then works ok. But I don't understand why it always happens right after turning my computer on. Has there been a change to Mathjax in the past 1+ weeks?

    I'm still having this problem with Safari on my macbook. I've tried clearing my cache, but that doesn't help. To recall -- when I start up my macbook I run Safari which restore all open tabs. Invariably I get repeated popups for all of the MO pages warning me of slow scripts. Continuing never helps. I have to stop them (sometimes multiple times). Once things settle down, I can go to the individual pages (all of the MatJax rending hasn't happened) and refresh, which usually happens right away. Any suggestions?